SFML Atom issue


#1

Hello,
I want to use SFML libraries with Atom. I downloaded Mingw and Cmake. Everything went fine and I have SFML dll’s, I copied them where the main.cpp is and when I want to compile it says: ‘D:\atom’ is not recognized as an internal or external command,operable program or batch file.". My project is in D:\atom saves and that’s why it only says D:\atom(because there is a space). What did I do wrong? Should I add a PATH in environment variables? Did I do something wrong? When I run main.exe it says ‘Entry point not found in X’. I think that’s all. If you need some more informations just comment down below.

Have a nice day!


#2

Atom doesn’t have support for compiling or building programs on its own, so I assume you’re using an Atom community package to perform this task? If so, you should probably mention which package that is. Additionally, you may want to reach out to the developers of that package to see if they have any suggestions.


#3

In package called gpp-compiler I’ve added in “C++ compiler options” this line:
-ID:\SFML-2.4.1\include -LD:\sfmlB\lib -lsfml-graphics -lsfml-window -lsfml-system

Pretty much it’s linking libraries. Well, my friend did it that way and it worked for him. That’s just weird.

Thanks for respond!