Settings Pane opening up in odd place


#1

This has happened a few times, not sure what causes this, but the only ‘solution’ I have found is to do a clean install.

Normally the settings pane will open up in the main editor area. Either by using Ctrl+, or File --> Settings (or any other way to get to that pane).
However, sometimes (and once it happens once it won’t stop), this will open in what appears to be the “navigation pane”. I don’t think its truly the navigation pane though, but another pane on top of the navigation pane.
The only way to get out of this “settings” page is to then right-click on the area and select “close pane” (or Ctrl-W).
You can’t get to the tab at the top, you can’t move the pane or tab somewhere else.

It almost seems as if this is the result of a bad package installed, but I don’t know what package. I have tried to uninstall packages and/or disable them to get it back to “normal”. But to no avail.

Currently this is on the latest version of Atom (1.32.2) for windows 64 on Windows 10. This has happened on 3 different Windows machines that I have used. This has also happened on several versions of Atom, since about 1.2x? (I didn’t really take note at the time, just did a Google search with no results and did a fresh reinstall).

Its hard to reproduce as I can’t “undo” it without a clean reinstall. I don’t do anything out of the ordinary or different, its just one time seemingly random time I am looking to do something in my settings and I will hit Ctrl+, and then it pops up over the navigation pane.

This is just really odd behavior, please help … :tired_face:

Regular window

Settings pane in odd place

Trying to close the settings pane


#2

The docks work a lot like the central panes, and you can drag pane items between them. This is trickier since you’ve hidden the tab row for your left dock (presumably because you only use it for the tree view and were getting annoyed with seeing an impotent Project sitting there). If you remove that style rule, you should be able to see the tabs for that dock and drag the settings view back to where it usually is.


#3

Regarding…

… I don’t have it hidden at all. As you could see in the first image (below).

The project pane doesn’t work like the central pane / editor panes. There is no “top” or “tab” to drag from one pane to another. Sorry that is cropped out of view.

image


#4

May I see the contents of your styles.less file?

This is the default behavior since tree-view was changed to live in a dock instead of a side panel (and docks were introduced):


#5

I have the code and the screenshot listed below.
I don’t even have the “projects” tab header listed anymore like you are showing. I vaguely remember seeing that before on my install, but I don’t remember if/when/how I turned that off.

/*
 * Your Stylesheet
 *
 * This stylesheet is loaded when Atom starts up and is reloaded automatically
 * when it is changed and saved.
 *
 * Add your own CSS or Less to fully customize Atom.
 * If you are unfamiliar with Less, you can read more about it here:
 * http://lesscss.org
 */

/*
 * Examples
 * (To see them, uncomment and save)
 */

// style the background color of the tree view
.tree-view {
  // background-color: whitesmoke;
}

// style the background and foreground colors on the atom-text-editor-element itself
atom-text-editor {

	// scroll bar size
	::-webkit-scrollbar {
		min-width: 20px !important;
		min-height: 20px !important;
		background-color: #666D81 !important;
	}
    ::-webkit-scrollbar-thumb {
        background-color: #0F6602 !important;
        border-radius: 5px;
        border: #000 1px solid !important;
    }
}


#6

Hello.

What UI theme do you have active? Could you please activate (for the moment) something like:

Alternatively execute safe mode:
image

Thereafter follow the instructions given by @DamnedScholar. With that done, you are more than welcome to change the theme back to your own choosing.

Does this help you?
BR
.
.
.
.
.
NOTE TO ATOM DEVELOPERS
It would be most welcome if the terminal command atom --clear-window-state fixed this issue by restoring the default environment. Thanks for considering this feature.


#7

For themes…I was using
One Dark - One Dark
and I just switched (about a month ago) to
City Lights - One Dark

This issue pre-dates when I made this switch to using the City Lights UI Theme, although the current time reporting is with that setup (as shown in the image).

I have previously run atom --safe after closing everything (and sometimes even after a reboot) just to try to get to that point. However, that does not solve the issue. Yes, when I open Atom.io it does not have the settings area in that side pane, however it doesn’t have anything open. And as soon as I open the settings again, it goes right into the left side.
I have not tried the command atom --clear-window-state, but will try that next time. I would agree, that would be advantageous if something like that happened.
The initial images were after I closed everything, system reboot and then ran atom --safe. I only opened up a project on the side some reference.

On Friday (11/16/18), I did an uninstall and reinstall and that worked (as I had initially stated, this is the only way I have found to correct the issue). So I would love to take more screenshots and share them, but the problem is not current. I would also really like to know “how” or “why” that happens in general, and that might lead to some real solutions to correct this, however I can’t reproduce the issue.

Thank you for the help @danPadric and @DamnedScholar . I will try to keep you informed and let you know next time this happens.


#8

Here’s where the city-lights-ui theme hides the tree-view tab bar.

// hides project tab in tree-view ⬇⬇ (who uses this?)

.atom-dock-inner {
  .pane .list-inline {
    .tab {
      .title:before {
        display: none;
      }
    }
  }
}