Setting package tab create infinity error message


#1

All works fine. But something break atom. When I go to the settings and click to packages tab or updates tab, red error message shows me again and again. I tried to run atom from cmd console with --safe flag, but error remain.
Error: Uncaught SyntaxError: Unexpected token A.

file:///C:/Users/Bet/AppData/Local/atom/app-0.179.0/resources/app/static/index.html?..

Broken packages: setting-view package, notification package

Is it possible reset atom without reinstalling atom and reinstalling already installed packages?


#2

Maybe you can open a command line and type apm update, and maybe that is successful. I have no idea whether it will work, but perhaps it’s worth spending ten seconds to try.


#3

After run apm update:

Package Updates Available (1)

Would you like to install these updates? (yes)
stream.js:94
throw er; // Unhandled stream error in pipe.
^
Error: write EIO
at errnoException (net.js:905:11)
at Object.afterWrite (net.js:721:19)


#4

Ayee. This is looking bad. So maybe you have to get a list of installed packages, then uninstall Atom and the packages, and then install the new version of Atom, and then install all those packages again.


#5

I delete atom files from:

  1. C:\Users\Bet\AppData\Local\atom
  2. C:\Users\Bet\AppData\Roaming\Atom
  3. C:\Users\Bet.atom

Then I download fresh Atom installer for Windows directly from https://atom.io/
Then I intall atom without installing any additional packages.

Error remain(


#6

hm, probably the error occur after I set default charset for command line to UTF-8. I restore system registry and that’s OK.