Self-updates with non-admin OS X account

If your primary OS X account is a non-admin user, for security purposes, the self-update functionality fails.

Updates are detected and downloaded correctly. However, after a a duration of time suggesting the download has occurred, a prompt is displayed stating: “There was an error checking for updates. Installation in progress”.


I am seeing the same error when attempting to update from 0.71.0 using “Check for Update” from the Atom menu. I have Atom installed in ~/Applications, which didn’t require admin privileges to install. The only thing that required admin privileges was installing the shell commands, which prompted for an administrative account.

For now, I can update by deleting Atom and downloading a new zip file from the Atom site.

1 Like

I, too, see that the only way to update on OSX (even in an account with admin privs) is to download the latest version (0.8 for some reason, rather than 0.81) from the website. I am worried that this is going to knock out the packages I’ve installed… well - I guess I’ll find out!

I found a fix for the update issue. When starting atom in the foreground, I see the following:

2014-04-24 09:25:48.397 Atom[2618:507] App load time: 257ms
[2620:0424/] Renderer process started
[2618:0424/092550:INFO:CONSOLE(18)] "Window load time: 1374ms", source: /Users/tim/Applications/ (18)
2014-04-24 09:26:16.763 Atom[2618:1372b] Download completed to: file:///Users/tim/Library/Application%20Support/com.github.atom.ShipIt/update.Nh9EA0Q/download
Error Downloading Update: Installation in progress

I took a look at the ~/Library/Application Support/com.github.atom.ShipIt directory and found a few files there. The stderr log file had some messages dated 3/10 (probably the first time the update failed) trying to install to the /Applications folder. I quit Atom, renamed the com.github.atom.ShipIt directory and restarted Atom. The update completed successfully and I was able to restart with the new version.

I hope this helps others who might still be experiencing this issue. It looks like a failure in the update kept the state around and Atom thought it was still trying to update, hence the “Installation in progress” error.

Thanks to @ProbablyCorey for the debug tip in "Check for update" disappears from Atom menu.


@twoods solution worked for me as well; identical problem, described in "Check for update" disappears from Atom menu

@twoods you are not a “non-admin” normal user account if you can install Atom without requiring an admin password.
this discussion is regarding “non-admin” users. default for a new user is “admin” account.

To clarify for everyone, the update is detected and download properly to com.github.atom.ShipIt. But because our account is a “non-admin” writing files to the /Applications folder is restricted. It is not possible for Atom to update the flies in /Applications unless the updater is granted admin privileges.
My recommended fix is to have the updater run as an admin, this will prompt the “non-admin” to authenticate as an admin user to write files to /Applications and complete the update.
I am not surprised the auto-update is failing as that is by design for the “non-admin” user accounts. But when other apps auto-update I am prompted to authenticate as an admin to complete the update process.

Until there’s a solution that is requesting administrative rights before running the updater, it would be nice to communicate to the user, that automatic updates don’t work. Ideally, this would happen before downloading the update.

Not sure if it matters, but it’s the same with Chrome’s auto-updater.

Thanks @rockymadden!