Self-signed cert checks?


#1

Hi,

I don’t have apm, there is another way to do that?


How do I disable self-signed cert checks in Atom?
#2

apm is installed with Atom. So you do have it. What OS are you using? What version of Atom are you running?


#3

Hi,

ok sorry I actually don’t have Atom, using only electron so I changed the .npmrc file but that didn’t solve my issue.

I’m running Electron on Mac OSX.

What should I do?


#4

Maybe you should start at the beginning then and describe what it is you’re trying to do and what is going wrong?


#5

Hi Lee,

I’m using Electron and BrowserWindow API. Part on the work I’m doing is load a page and use WebRTC with javascript API getUserMedia().

Since some chrome versions, getUserMedia() is only available for https pages so for my development I’m using localhost with https. On chrome when I load my localhosted page I have to accept the self signed certificat (using an appearing chrome dialog box), then the page is loaded.

When I’m loading the same localhosted page on the BrowserWindow I got an error Failed to load resource: net::ERR_INSECURE_RESPONSE

I tryied to use strict-ssl=false like I read on some post except I set it on .npmrc file and not on .apmrc because I’m not using atom.

So finaly I’m looking for a way to do something like disable web-security and so accept automatically self signed certificated, or may be there is a way to autorize electron to use getUserMedia() even if it’s not over https.

Make sens ?

Thx for your time


#6

Hi,
I have the same problem with self signed certificates. If I set strict-ssl to false it doesn’t help to solve the problem.
I got an error window on loading Atom from sync-settings that no backup is possible because self signed certificate in chain.

What can I do?