Select code inside matching brackets does not work


#1

Am trying to use Ctrl+Alt+m to Select code inside matching brackets, but its not working. Can anyone give me a solution for this problem.


#2

You can open the Keybinding Resolver (Packages -> Keybinding Resolver -> Toggle) and then enter the key sequence to see which commands trigger when you press it. Please post a screenshot here. You can also search your keybindings (Settings -> Keybindings, enter ctrl-alt-m) to see the specific command and scope defined for the keybinding.

Are you using a package that’s supposed to give you this keybinding?


#3

No its not a package,I saw the shortcut on the following link (https://shortcutworld.com/en/Atom-(text-editor)/1.0/linux/all).


#4

It’s not a default Atom keybinding. Going to the bracket-matcher package (Settings -> Packages -> bracket-matcher), I can see that a command called bracket-matcher:select-inside is bound to ctrl-alt-,, and that command seems to be what you’re looking for.


#5

Ok thanks alot got it.