Segmentation fault when trying to install packages and themes from both command line and atom user interface


#1

I newly installed Atom on Ubuntu 17.10 via Ubuntu Software.
But I cannot install any package nor theme, neither from the user interface nor from the terminal.

This is what I get in the +Install Packages pane (left side):

On the rigth side is what I get from the terminal using $ apm:

Segmentation fault (core dumped)
"$binDir/$nodeBin" “cliPath" "@”

Thanks to anyone who could help me. :pensive:


Can't install packages after reinstalling linux
#2

had the same issue. seems like apm doesn’t work with ubuntu snap…Ended up uninstalling and installing using the deb package from https://atom.io site. Worked then.

EDIT

Found someone had already raised an issue about it Cannot manage/update packages, cannot update Atom core


#3

It seems like you are right! :slightly_smiling_face:

I uninstalled and installed using the debian package. It’s working fine!
Thanks