See spaces in text


#1

I want to start by saying Atom is a beautiful tool. I’m just getting started in HTML and Atom has everything I need, with 1 exception. I cannot see spaces in my paragraph text there are no markers or spaces. I’ve turned on the invisible characters and still don’t see anything.
no spacing is fine in the code, but when I’m inputting the display data it would be very helpful so see. OtherwisethepagelookslikethisineditingandIcanttellifIaccidentlyhitthespace2timesormisseditalltogether.


#2

What font are you using? (Please share both the font that’s declared in Settings and also what’s actually being displayed.) Can you provide a screenshot? To inspect the editor elements, check out View -> Developer Tools -> Open in Dev Mode..., select your project folder, and then right-click on one of the affected paragraphs and select Inspect from the context menu. It will open a dev tools pane focused on the element you clicked on, and from there you can see what CSS rules are governing how the text is being displayed.


#3

So as I’m typing I get a . when I add a space, but then when I type the next letter the space disappears. I even removed all of atom and reinstalled fresh with the same result.

“*”:
core:
openEmptyEditorOnStart: false
themes: [
“atom-dark-ui”
“chameleon-dark-syntax”
]
editor:
fontFamily: "roboto mono"
fontSize: 16
invisibles: {}
preferredLineLength: 160
scrollPastEnd: true
showIndentGuide: true
showInvisibles: true
softWrap: true
softWrapAtPreferredLineLength: true
tabLength: 4


#4

this is my work around to see the spaces.


#5

Okay, so I still don’t know what the root issue is for sure, but one thing I can tell immediately: the font you have listed in settings is monospace and the font that’s actually displaying is not (it looks like Times New Roman). In the dev tools window, in the lower right-hand section, type “font” into the filter box and you’ll see the font that’s actually being displayed.

So the first step to trying to figure out what’s wrong is to switch your fonts. Unset “roboto mono” and see what shows up.


#6

This is a known issue: