Scrollbars on OSX?


#1

Has anybody got scrollbars that you can actually see with a dark theme under OSX? I’m running 1.6.2 under OSX 10.11.4.

Mine only show up when I scroll (sometimes) and are virtually invisible… :cry:

I’ve got the following in my stylesheet:

.scrollbars-visible-always
{
    /deep/ ::-webkit-scrollbar
    {
        width: 10px;
        height: 10px;

        &-track
        {
            border: 0;
            border-radius: 0;
            background-color: black !important;
        }

        &-thumb
        {
            border: 0;
            border-radius: 0;
            background-color: #420 !important;
        }
    }
}

but it doesn’t seem to be doing anything…


#2

I have this on mine (based in part on something posted here just a few days ago). It’s a pale reddish thing - not very OS X like - that matches my dark theme, but can certainly be tweaked to whatever colors your scheme uses.


/ Change scrollbar styling
.scrollbars-visible-always {
  /deep/ ::-webkit-scrollbar {
    width: 20px;
    height: 20px;
    background-color: rgba(255, 255, 255, 1);

    &-track {
      background-color: #a08080 !important;
      box-shadow: 3px 3px 10px rgba(0,0,0,.25) inset;
    }

    &-thumb {
      background: rgba(80,40,40,0.5) !important;
      border-radius: 10px;
      border:1px solid rgba(0,0,0,0.9);
    }
  }
}


#3

Still not working for me. Must be another setting somewhere getting in the way?


#4

Perhaps. The key thing, I think, is this should not be inside an atom-text-editor selector - it’s standalone. Make sure, too, that you don’t something else in the file that overrides it, and that there are no syntax errors in the file causing issues. I suggest just trying it with everything else in the style sheet commented out.


#5

I tried it with nothing else at all in the stylesheet with no luck. The other styles were working so I don’t think it’s a syntax error either.

Doesn’t work if I start in safe mode either, so I don’t think it’s another extension causing problems.

Curious…


#6

Sounds to me like you need to adjust the system-wide settings for scrollbars. Launch System Preferences and click General to change the setting:


#7

Thanks for the suggestion, but it didn’t help. Bizarely, I’m using my work macbook pro now, which is virtually identical, and the scrollbars behave correctly!?

I copied the entire .atom folder from the work machine to the home machine, but it’s not working… I’ll have to got through all the system preferences and see what’s different.

Thanks for the help, but I’m coming to the conclusion that it’s not an atom issue I think…


#8

Dunno if you missed idleberg’s suggestion, but it’s a good one. I have my scroll bars set to “Always”, and the styling works. If I switch to either of the other two choices, it doesn’t work.


#9

You guys cracked it - it needs to be set to Always as you say. It looked like idleberg was suggesting it needed to be set to Automatically based on mouse or trackpad.

Seems a bit stupid that a mac system preference should affect the display? I could understand them appearing when the mouse or trackpad moved, but I’d still expect them to be styled properly…