Script Runner - How to set a default python to be python3?

Unless I add a shebang line into my script, Script Runner always runs python scripts in python 2.7 interpreter.

Where and how can I adjust Script Runner to use python3 by default?

In my view process-palette offers more flexibility. You could have two commands …
one for python2
the other for python3

and add arguments such as filepath.

And you can add these commands as tool bar entries (Run, Python).

Or outside Atom declare python3 as default python. No need for shebang. Look at miniconda.

I just tested process-palette and it works. Unfortunately, process-palette’s terminal isn’t interactive, I cannot run scripts that require input. Input scripts only work in Script Runner.

Can you expand on how to declare python3 as default python using miniconda?

I encourage you to use the Search feature at the top of this page. Search “python input” and you see why there is no input capability with some packages. Here is just one thread from the search “python input”.

Regarding python3 / conda the conda manual will explain the setting of python environments. Really no need to repeat it here.