Says python isn't installed although it is

I apologies in advance as I am very new to coding but anyways here it goes. Basically, when I open up atom I get a prompt that says python is not installed I have tried re-downloading it and adding it to PATH(I think that’s what it is called the box on the button during setup). The pop up prompts me to type python -m pip install 'python-language-server[all]' I have done this and it comes up with ERROR: Invalid requirement: “‘python-language-server[all]’”. I am very confused because I originally got a different error, maybe I fixed something.
Thank you for reading this mess.

So it somehow just fixed itself, I woke up and it works now. But I can’t delete the post.