[Save] extra line added


#1

Whenever I edit and save a file, a newline is appended at the end of the file (at least with JavaScript: this may be specific to a filetype): is there a way to configure this behavior ?


#2

You might want to read this discussion before you try to override that behavior.


#3

It looks like you can turn off the behavior by going into Preferences > Whitespace and unchecking the checkbox for “Ensure Single Trailing Newline.” But I’d leave it checked, too.