SASS auto indentation not working


#1

I am using Atom out of a box + Emmet. When I hit return in .sass files the new line does auto indent, but it does work in .scss and .css files. Sass files don’t use brackets, but there must be a way to auto indent like in other code editors.

Any ideas? Thank you!


#2

You mention that you have Emmet installed. Does Sass auto-indent properly when you run Atom in Safe Mode?


#3

I ran Atom in safe mode. Same problem. If I use curly brackets, it does auto-indent new line even in safe mode. Only if brackets are not used it does not indent.

Could it be some kind of setting I am missing?

Thank you!


#4

Can you record a GIF of exactly the problem you’re having and post it here? If not, can you give exact repro steps so that I can see the issue for myself?


#5
https://www.files-conversion.com/file-convert/Untitled.swf

#6

You didn’t include the status bar in this GIF. Is the file being recognized as a Sass file or an SCSS file?

Also, since you filed an Issue, I figured I’d include the link to it here:


#7

Sorry for not including status bard.

It is recognized as a Sass file.

I also tried ST3 and Brackets. Brackets does indent, but not ST3.

Thank you.


#8

Apparently this is not a bug, but a feature. It also works after first line is manually indented, then the following will auto indent. Thank you!


#9

It also works after first line is manually indented, then the following will auto indent.

I’m still having this problem and not sure what you meant by this?

Here’s a GIF:


#10

@ryanmack, I can’t reproduce what you’re seeing using Atom v1.5.0-dev-5d85ea1 on Mac OS X 10.11.2:

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have Emmet installed?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#11

@leedohm I have looked at the debugging docs.

  1. Atom v1.3.2
  2. Mac OS X 10.11.2
  3. Yes (tried removing, still happens)
  4. Still was able to produce in atom --safe

#12

Do you have the “Auto-Indent” setting enabled?


#13

Yes


#14

Please file a bug on the atom/atom repository with this information. I don’t know why you would be seeing this behavior.