Sandboxing Error

As of today, I can no longer open atom. This happened in the last 24 hours. When I try to open it on Debian 10, I receive the following message:

usr/bin/atom: line 190: 4870 Trace/breakpoint trap nohup “ATOM_PATH" --executed-from="(pwd)” --pid=$$ “$@” > “$ATOM_HOME/nohup.out” 2>&1
[4870:0520/013613.155976:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that /usr/share/atom/chrome-sandbox is owned by root and has mode 4755.

If I try to run it as sudo I receive the following message:

/usr/bin/atom: line 190: 4411 Trace/breakpoint trap nohup “ATOM_PATH" --executed-from="(pwd)” --pid=$$ “$@” > “$ATOM_HOME/nohup.out” 2>&1
[4411:0520/012555.093040:FATAL:atom_main_delegate.cc(194)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

This happens on all my Debian Machines. Any help would be appreciated .

2 Likes

I have exactly the same issue, in Debian 10 too having just done a:

sudo apt upgrade

and accepted the new 1.47 package to upgrade from 1.46

$ atom 
$ /usr/bin/atom: line 190:  5994 Trace/breakpoint trap   nohup "$ATOM_PATH" --executed-from="$(pwd)" --pid=$$ "$@" > "$ATOM_HOME/nohup.out" 2>&1
[5994:0520/103214.550985:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /usr/share/atom/chrome-sandbox is owned by root and has mode 4755.

In the end, since I had installed via adding the atom repository:

 deb [arch=amd64] https://packagecloud.io/AtomEditor/atom/any/ any main

I just downgraded back to 1.46.0:

$ sudo apt-get install atom=1.46.0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  gir1.2-gnomekeyring-1.0
The following packages will be DOWNGRADED:
  atom
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 0 B/121 MB of archives.
After this operation, 17.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
dpkg: warning: downgrading atom from 1.47.0 to 1.46.0
(Reading database ... 143334 files and directories currently installed.)
Preparing to unpack .../archives/atom_1.46.0_amd64.deb ...
Unpacking atom (1.46.0) over (1.47.0) ...
Setting up atom (1.46.0) ...
Processing triggers for mime-support (3.62) ...
Processing triggers for desktop-file-utils (0.23-4) ...

Now atom launches without a problem. This is a Bug in packaging failing to set the sandboxing up correctly. So we are stuck on 1.46.0 till they fix it.

1 Like

Don’t suppose you could change this post’s title to something like: “1.47.0 Does not open on Debian 10” , since we now know it’s not something specific to your setup. I’m hoping it might get a bit more interest from Atom Support people.

There is an Issue in place on the github project : https://github.com/atom/atom/issues/20756

Just do as suggested:

sudo chmod 4755 /usr/share/atom/chrome-sandbox

to activate setuid bit permission and it will work.

4 Likes

There was no action after I ran the code

Same issue in Ubuntu 18. Downgrade to 1.46.0 got things working again.

Same issue with Debian Bullseye. Just did as suggested:

sudo chmod 4755 / usr / share / atom / chrome-sandbox

It works!

Same issue with Red Hat Enterprise Linux.

Doing sudo chmod 4755 /usr/share/atom/chrome-sandbox fixes the issue.

1 Like

Incidentally, is this a “new feature” - I notice that this file doesn’t exist in the previous version.

Not an option. In my environment, atom is installed in my HOME directory which is on a filesystem based on NFS, and we are not allowed to change ownership of those files. I read elsewhere that using the –no-sandbox option was a workaround, but every time I do that I get the following annoying error when invoking atom:

$ bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell

work for me on version 1.47.0 x64