Sample application not running


#1

So I’m just new with Electron js and creating my first project now, I have a problem though in running the sample app found in the GitHub docs/tutorial/quick-start.md

I have electron installed globally via

npm install electron-prebuilt -g

Then I just copied the codes for the files package.json, main.js, and index.html. All the same contents without editing anything.

Then I run electron . on the project directory, it pauses for a moment, and goes back to console input without anything happening, not even errors nor output on the command line:

There is no window showing up, or anything.

I tried checking the task manager, and when I run electron ., the process electron.exe runs for a moment and then disappears. I am not sure if this is the default behavior or this is a crash.

EDIT: I tried others like electron-sample-apps and also doesn’t work


#2

What OS are you’re running this on? Also, if you can avail yourself of a fresh OS installation inside a VM, can you reproduce the issue?

Possibly related issue: https://github.com/mafintosh/electron-prebuilt/issues/54


#3

I am on Windows 7, no service packs installed.

Might try testing on VMWare or on my laptop, but no guarantee, been busy lately