Safe mode for packages?


#1

I am new to atom and as I add packages the bugs seem to be getting more frequent. I may be mistaken because I’m just finding new ones as I use it, but that’s the way it seems.

Is there a way to disable all added packages or arbitrary sets of packages, sort of like starting windows or firefox in “safe mode”?

Right now I’ve lost the ability to double-click on a word and surely this is a bug in a package since it’s too serious to be in core.

I’ll go through and disable packages one by one but that is a pain.


#2

Atom has a safe mode feature, that starts with all non-bundled packages disabled. Simply start Atom by executing atom --safe from your terminal.


#3

Duh. I should have known that. Thanks.


#4

Safe mode appears to be a bit too safe. I get a window named “untitled” with only the menu bar. If I then try to do something like open a file or open a folder a new window appears not in safe mode. I can’t even see the tree-view which is where my problem is.

Apparently --safe disables all packages including the pre-installed ones. This means I can’t test the problem I was having.

Oh well … back to disabling individual packages.


#5

You should always be able to bring up the tree view by pressing Ctrl+\ (on Windows). You might want to submit a bug … because disabling all packages is not the intended behavior of Safe Mode.