Running specs shows 0/0 ran


#1

If I navigate to …/[any package]/spec/some-spec.coffee and follow these instructions (from the generated spec file produced from package-generate):

“Use the command window:run-package-specs (cmd-alt-ctrl-p) to run specs.”

…when I run the spec a second window pops up showing “0/0, 0 failures” (looks like jasmine runner). It appears the tests are not actually running at all.

When I instead navigate to …/[any package] and run apm test then the tests run and I get something like, for example: 2 tests, 3 assertions, 3 failures

Please help me figure out what I might be doing wrong. :blush:

I’m trying to get to a workflow where I can develop a package in atom, run the tests from right there, and use the developer tools (chromium debugger, specifically) while testing. Any tips to help me achieve that workflow are very welcome as well.


#2

Alright, so followed instructions posted to another thread here and that seems to have resolved the weirdness I was seeing…now I’ll see if I can narrow it down to the offending package or action I took.

Now, any pointers on how to use the debugger while running the specs? Is it even possible?


#3

If you can open the spec window cmd-alt-ctrl-p and open the dev tools cmd-alt-i you should be able to set breakpoints. Then press cmd-alt-ctrl-l to reload the specs it the breakpoints should hit.

Alternatively you can use the debugger keyword.


#4

Thanks, didn’t realize the reload command would work on the test results window and hadn’t thought about debugger keyword, although the other would be preferable.

So…problem though. This a.m. before work I was working through the package creation tutorial and also trying out test-status plugin…making sure I ran some specs as well…everything working fine.

I go to work and use atom in my day-to-day…come home…and now the specs no longer run. I’m back to 0/0. Now that I can get into debugger, I open it up and see the problem. The specs are not being loaded at all!

I don’t know what happened through the course of my day to get to this point, but I think over the weekend I’ll reset everything and pay more attention.

I definitely believe there is a bug lurking somewhere here.


#5

Ok, not sure I’d call this a bug…but in order to run specs and have it find them you need to open atom from the directory containing the specs/ folder.

Now that I know and can move on, I’m satisfied.