Running electron and get nothing on Ubuntu 14.04


#1

Hi guys,

I’m trying to learn how to use electron and followed the project electron-quick-start. Every thing works fine until I tried to start the app usingnpm start, I can saw npm was running but the main window of app just didn’t show up as excepted, and no error nor info was logged on my console, the process was running, waiting to exit.

I’ve found an similar issue on Github and trying to logging electron output, unfortunately, it’s not work on my sutiation, I still get nothing from console, like this:

keith@ubuntu:/home/sources/electron-quick-start$ ELECTRON_ENABLE_LOGGING=1 ELECTRON_ENABLE_STACK_DUMPING=1 ./node_modules/.bin/electron -v
[blank line]

Here are some details of my env:

electron: v1.7.9

root@ubuntu:/home/sources/electron-quick-start# uname -a
Linux ubuntu 4.2.0-27-generic #32~14.04.1-Ubuntu SMP Fri Jan 22 15:32:26 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
root@ubuntu:/home/sources/electron-quick-start# node --version
v8.9.3
root@ubuntu:/home/sources/electron-quick-start# npm --version
5.5.1
root@ubuntu:/home/sources/electron-quick-start# apt-get install libgtk2.0-0 libnotify-bin libgconf-2-4 libnss3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgconf-2-4 is already the newest version.
libnotify-bin is already the newest version.
libgtk2.0-0 is already the newest version.
libnss3 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 291 not upgraded.

By the way, I’m running electron on a Ubuntu VM with gnome desktop, and I access it by VNC connection, I’ve found an issue on Github about xrdp problem and tried with the hack provided by @groone , unfortunately, again, it wasn’t work for me.

This strange problem puzzled me for days, if anyone knows why this problem happened or how to find out the real problem, please let me know. Thank you so much.