Rookie HTML question about plug-ins

Super new to coding! The class I’m taking came with a bunch of suggested plug-ins including Emmet where I believe the problem lies. When I open a new file and start typing html I’m not seeing the boilerplate shortcut, or any simple shortcuts for that matter, as I had seen on the first little site I made. Do I need to re-download the plug-ins? I have this error message when opening new files:

The “git” command requires the command line developer tools. Would you like to install the tools now?

and then >> Can’t install the software because it is not currently available from the Software Update Server

to see boilerplate shortcut what u mean u can hit CTRL + [space], or maybe u can install other package like autocomplete-html, atom-html-preview and many.