Reverted to v101?


#1

Hi guys,

I’ve just tried to build to the latest version on Windows.
It all goes through fine, no npm or gyp errors, all green and ok.

I launch Atom and this is the version the help menu tells me I have now:

Mind you, on this machine I was on 106 prior to the rebuild, and now it shows as 101?

If I open the version file in the atom directory, it shows me this:

…which is more like it, although I thought the latest was one 109.

Secondly a whole bunch of packages now don’t work anymore, for example the bracket matcher to name just one, but I get errors for a ton of them:

… which indicates further that it really was an older version that was cloned down from git during my build with git clone https://github.com/atom/atom.

I’ll try the build again later today, but I wanted to mention it.
I’ll open an issue as well, once anybody can confirm that it’s not just my stupidity. Has anyone else tried today?


#2

Looks fine to me on OS X:


#3

Yea maybe I just accidentally built from the wrong repository folder or something, although for the life of me I can’t image how, since I created fresh folders for the build as I always do. :worried:

Anyway. Unless someone cries out reporting the same thing soon, feel free to close this thing @leedohm.


#4

Alright all fine now.
I did a clean rebuild again and it’s on 109 as expected.
Sorry for crying Wolf here.


#5

No problem … that’s what Discuss is here for :grinning: