Restart and update does not work (MacOS)

Ok the issue is still not solved… if you try running the update as none-admin it will silently fail :frowning:

This might be obvious, but also make sure Atom is installed in the Applications directory.


For me I was running Atom out of my ~/Downloads directory. After moving to /Applications/ the update worked.

NOTE: All the plugins and setting are in ~/.atom/* so deleting, moving, upgrading, downloading the directory should have no effect on settings or environment.

1 Like

This is the best resolution available for the issue

Run the following command (remember change the your_user_name parts to your username): sudo chown your_user_name:staff /Users/your_user_name/Library/Caches/com.github.atom.ShipIt/*
should fix this problem.

1 Like

I have a MacBook air (2016) with OS Sierra. This from @ryanbaer resolved my issue as well, but I next implemented what @rahmanifarid did in his solution (see below in this post). After which I went into Atom clicked the install/restart. It took 3-4 minutes and the Atom restarted on its own with the update installed. So to recap do the following steps:

  1. sudo chown -R $(whoami) /Applications/
  2. sudo chown -R $(whoami) ~/Library/Caches/com.github.atom.ShipIt/
  3. sudo chown -R $(whoami) ~/Library/Application\ Support/com.github.atom.ShipIt/
  4. sudo chown (whoami):staff /Users/your_user_name/Library/Caches/com.github.atom.ShipIt/*
  5. Go into Atom and click restart/install and wait for 5-10 minutes ( if it doesn’t come back on its own, check your steps).
  6. If it works, volia!

(whoami) = your_user_name = you username on you device that you’re using (ex: /User/whoami/myFolderName/myNextFolderName

Thanks to everyone including: @rahmanifarid and @ryanbaer for the insight!


Please see my reply to @ryanbaer to see how I dealt with the problem using an abridged version of both @rahmanifarid 's and @ryanbaer 's solution. Hopefully I clarified the waters a little.

For any consolation, I have a Mac 10.12.3, now with Atom 1.17.2, and the icon is saved on my Dock.

I thought I used to have this problem with earlier versions of Atom, even to 1.12 or before.

I remember clicking to re-open Atom, in case that was incorrect.

Updating even today to 1.17, it was working, even waiting with the editor closed for more than 15-20 seconds.

I reopened Atom, clicked update, and proceeded to wait again, and after a similar while, it opened by itself, and was updated.

Thanks buddy! This worked for me w/o any hickups.

My Mac - MBP Early 2015 13" 128SSD, macOS High Sierra Beta v9

Try using this script:

It follows the steps in this post: I am unable to update to the latest version of Atom on macOS. How do I fix this?


This solved my issue.

Was the issue for me too

I restart atom, go to About. About says it’s version 1.23.2 and the new update is 1.23.3. I click “Restart and Install” and wait a half a minute. Atom restarts. I click about and it’s still at version 1.23.2.

I ran the script (I already checked all the file ownerships, but I ran it anyway). That didn’t work, so I deleted the directories ~/Library/Cache/com.github.atom and …/com.github.atom.ShipIt.

I have MacOs 10.13.2.

The only way I’ve been able to update Atom is to download the new version and replace it in my Applications directory.

I have a similar problem on Windows. When Atom asks me to Restart to update, it closes and updates, but doesn’t reopen. I have to manually start the application again after I hit the “restart” button to update it. I’ve waited a minute or two, and nothing happens unless I start it up myself. However, it does update, it just doesn’t open back up afterwards like it’s supposed to.

What happens when you use ctrl-shift-f5?

Steps 3 & 4 both come back saying No such file or directory for me. I’m on High Sierra and Atom 1.24.1 - has something changed or is there a reason I might not have those directories?

This just happened to me with 1.25.1. Clicking the squirrel closes the window but leaves the application open. I even let it sit like one user mentioned. The program did open back up but it would not open any files and it wiped out my project sidebar. So I pretty much had a blank window.

Next, I removed the app from Applications and put the new one in there. Still had same problem.

What worked for me was going into Finder > Applications then right click on Atom and hit open. Sounds dumb as hell but I think doing that is some type of admin action. I’m not 100% sure though.

Anyway, hope this helps someone.

I found the answer from @leftstick to point me in the best direction for resolving this recurring issue on my own machine.

I noticed ~/.atom/storage/ contained data to open any projects I currently had open. So, I tried closing all active projects/windows, and then hit the Install and Restart, and Atom did just that. It finally installed the update and restarted.

Therefore, I agree that this is probably a caching issue preventing the update from installing (or Atom from actually closing).

This is still an issue 2 years later. Probably every 2nd or 3rd update I have to go searching to find a solution, which often involves manual download and installation. It doesn’t seem like it should be this hard to fix.

1 Like

Yeah I just gave up on this ever working. I see the notification. It just tells me I need to do everything manually by going to the site, downloading and installing the old fashioned way. At least the notification works I guess