Restart and update does not work (MacOS)


#1

Hi,

For several versions now (at least since 0.150), I cannot update my atom (on Mac) properly.

When I click on the restart and update button atom is closed but never restarted. When I open it again, it is still in the old version and start downloading the new update.

Until now, to update my atom I have to download the new build on your website, delete my atom and install the new one.

No idea why I have this behavior on my mac but the first time, I may have install atom on my clean MacOS install using brew cask. Afterward, I deleted it and installed it normally… so maybe it has broke something…


#2

I don’t know if the brew-installed version works with the auto-update feature. Brew normally manages your updates through its own mechanism. Can you uninstall the brew version and install the version of Atom from the https://atom.io website and see if that fixes it?


#3

Maybe it was not clear in my post but I already uninstalled from brew cask for a while now (since 0.150) :confused:


#4

It takes quite long for Atom to restart. I used to think it just died. But then one time I got distracted, which gave it time to finish, and then I realized it just took long.

Next time, try to initiate the “upgrade and restart” before lunch, and if you take your time to eat, it might be done when you come back :smile:


#5

I think @kgrossjo has it right. Sometimes it just takes a while, and re-opening it while it is in the process of updating seems to be… counterproductive. I banged my head on this a while ago until I just made sure I only had one window open when I hit update, and avoided starting another atom instance until it started up by itself. No problems since.

Homebrew shouldn’t be an issue here since it is a cask. Like many other (most?) casks, homebrew just gets it installed on your system and permits it to update itself, and you won’t see homebrew call atom outdated since it can self-update. I can’t say with absolute certainty that brew cask isn’t at fault here, but I’d be very surprised if it is conflicting with squirrel in any way.


#6

I didn’t mean to imply that it was necessarily at fault, just that I hadn’t tried it and therefore couldn’t rule it out.


#7

Ok I give a try, it is 19:18 here, I just launched the restart and update process.


#8

The tension is killing me! What happened?

It took some minutes for me, but never an hour. I think if it hasn’t happened within five minutes, then either you have a slow system or something is actually wrong.


#9

It is now 22:57 and atom has not restarted yet :smile:

So I guess the problem is not a matter of time


#10

Yes, indeed. Not a matter of time. I have no idea what to do next, except for the cheap idea to download the most recent version and do a fresh install. :frowning:


#11

The issue is caused by the cache, you have to clean the cache files manually in ~/.atom/storage/.

And restart atom again, it will be fine


#12

I’m having the same issue with 1.0.19.

Cleaned out the storage folder, but Atom still doesn’t restart. Opening it again reveals the old version.


#13

Delete the old version and download the new version from the web site. There were some edge cases where it wouldn’t update.


#14

Clearing out the ~/.atom/storage/ directory worked for me. Thanks leftstick!


#15

The exact same thing happens to me on version 1.11.2 (not very long since I downloaded it for the first time). Every time I start Atom I get a popup from the OS that Atom has an update and that I need to insert my password to allow installation of a new support tool. After I have entered my password Atom says it downloads an update, and then I can choose Restart and install update. But Atom never restarts. And then it is the same procedure all over again: Still version 1.11.2 and downloading an update, OS-prompt for password, and then “Restart and install update” shows up.

I have tried to delete the atom/storage directory and wait a long time. Not helping…


#16

Try downloading a more recent version of the installer and installing it from there.


#17

Works on mine, thanks.


#18

OK, so I’ve been digging in on this issue for quite a bit today. Here’s what I’ve found:

  • The issues I experienced included:

    • A prompt from macOS asking for password, stating that “An update is ready to install. Atom is trying to add a new helper tool.” shortly after launching Atom
    • Clicking “Restart and Install Update” after entering password, and Atom does not restart. Upon relaunching, Atom has not updated
    • This issues mirror the one that @kesteinbakk faced
  • Atom updates, like many Electron apps, rely on the Squirrel Framework, which in turn relies on ShipIt

  • It seems that, between 1.11.2 and 1.12.3, something in the update framework switched from using ~/Library/Application\ Support/com.github.atom.ShipIt/ to ~/Library/Caches/com.github.atom.ShipIt/ as a staging area for updates

    • This is mostly irrelevant to the problem, other than knowing the directories where it stages
  • In my case, Atom had been installed by root in the past. As such, some of the files & folders in this directory were still owned by root. Try as the updater might, I’m guessing one of the files was unexpectedly owned by root and so the prompt didn’t help.

To resolve the issue:

sudo chown -R $(whoami) /Applications/Atom.app/
sudo chown -R $(whoami) ~/Library/Caches/com.github.atom.ShipIt/
sudo chown -R $(whoami) ~/Library/Application\ Support/com.github.atom.ShipIt/

i.e. fix the ownership anywhere they could have gone wrong. 1.11.2 uses ~/Library/Application Support and 1.12.3 uses ~/Library/Caches. For any case, if your Atom.app does not have correct ownership, things won’t work.

Hope this helps - let me know if I missed something.


#19

@ryanbaer Thanks, that solved my issue!


#20

This resolved my issue as well.