[resolved] 6 minutes for startup


#1

Hi,

I’ve just updated from 1.19.0 to 1.19.4 (on Debian 8.9) and suddenly the atom application needs 6 minutes to start. I’ve remove the package and reinstalled 1.19.0, and the problem persist (idem with 1.20.0.beta5).
I’ve tried to remove my ~/.atom directory, but no success.

after launching Atom from the command line, I can see those processes :

$ ps auwx | grep atom
jlecour   7378  0.0  0.0  15008  1684 pts/1    S    14:17   0:00 /bin/bash /usr/bin/atom-beta
jlecour   7380  0.2  2.6 1498192 212244 pts/1  Sl   14:17   0:00 /usr/share/atom-beta/atom --executed-from=/home/jlecour/ansible --pid=7367
jlecour   7392  0.0  0.3 374456 27868 pts/1    S    14:17   0:00 /usr/share/atom-beta/atom --type=zygote --no-sandbox
jlecour   7439  0.0  0.6 451492 49648 pts/1    Sl   14:17   0:00 /usr/share/atom-beta/atom --type=gpu-process --no-sandbox --supports-dual-gpus=false --gpu-driver-bug-workarounds=1,7,23,59,71 --gpu-vendor-id=0x8086 --gpu-device-id=0x1616 --gpu-driver-vendor --gpu-driver-version --gpu-driver-date --service-request-channel-token=5871526402D2A4EC994CAB0CB22FA8DC --v8-natives-passed-by-fd --v8-snapshot-passed-by-fd
jlecour   7452  0.1  2.4 1165040 198444 pts/1  Sl   14:17   0:00 /usr/share/atom-beta/atom --type=renderer --enable-experimental-web-platform-features --no-sandbox --primordial-pipe-token=BFEA1EA0CC5D106905652E6A113E8CF5 --lang=fr --app-path=/usr/share/atom-beta/resources/app --node-integration=true --disable-blink-features=Auxclick --hidden-page --enable-pinch --num-raster-threads=2 --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,3553;0,11,3553;0,12,3553;0,13,3553;0,14,3553;0,15,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,3553;1,11,3553;1,12,3553;1,13,3553;1,14,3553;1,15,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,3553;2,11,3553;2,12,3553;2,13,3553;2,14,3553;2,15,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,3553;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,3553;3,13,3553;3,14,3553;3,15,3553 --disable-accelerated-video-decode --service-request-channel-token=BFEA1EA0CC5D106905652E6A113E8CF5 --renderer-client-id=4 --v8-natives-passed-by-fd --v8-snapshot-passed-by-fd
jlecour   8332  0.0  0.0  14484  2160 pts/1    S+   14:22   0:00 grep atom

I don’t know where to look for logs. There is nothing in ~/.atom/nohup.out :

$ cat ~/.atom/nohup.out 
lock: Aucun verrou disponible

Timecop says that it’s the shell that takes 6 minutes.
I’ve just started Atom with the “profile-startup” option and will report the output.


#2

I don’t know where to look, but after startup, it has opened the web inspector and I’ve got this in the console output :

Profile 'startup' started.
<embedded>:18372 Could not connect to indexedDB 
Event {isTrusted: true, type: "error", target: IDBOpenDBRequest, currentTarget: IDBOpenDBRequest, eventPhase: 2…}
main.coffee [sm]:7 activate aligner-puppet
index.js:118 Switch to the Profiles tab to view the created startup profile
Profile 'startup' finished.
<embedded>:18372 Could not connect to indexedDB 
Event {isTrusted: true, type: "error", target: IDBOpenDBRequest, currentTarget: IDBOpenDBRequest, eventPhase: 2…}

#3

This problem was caused by another NFS issue, not related to Atom.