Requiring $ from atom is no longer supported


#1

I’m getting these errors when I run my specs now:

Requiring $ from atom is no longer supported. If you are using space-pen, please require $ from space-pen. Otherwise require jquery instead: {$} = require 'space-pen' or $ = require 'jquery' Add "space-pen": "^3" to your package dependencies. Or add "jquery": "^2" to your package dependencies.'

I’ve update my package and removed $ from all require 'atom's and required them via space-pen as suggested. However the deprecation warning does not disappear. Am I missing something? Everything runs as expected so it’s not really an issue at this point. Just want to stay up to date :smile:

Regards,


#2

Application: Run All Specs seems to also suffer from this. I guess It’s not cleaned up everywhere just yet?


#3

Where are you seeing these errors? I’m not seeing them. Is there a special way to show deprecation errors?


#4

When running specs for my package atom-build.
I also see them when I run all specs.

If you’re not seeing them, could there be something else at play here?


#5

Aha. I haven’t run specs in a while on anything.


#6

I’ve been looking at the Deprecation Cop messages and I believe that not all of this is cleaned up in Atom Core and default-installed packages, so you could be getting spurious messages depending on what APIs you’re calling. Check the Team Update topic for updates on the API Freeze: