"Require" package installation failed


#1

Im new to Atom. Tried to install the “Require” package from package manager and got the following error. Maybe I’m doing something wrong or is this a bug? Thanks

Atom Version: 1.7.4
System: Microsoft Windows 10 Home
Thrown From: require package, v0.1.0

Stack Trace

Failed to load the require package

At atom.project.getPath is not a function

TypeError: atom.project.getPath is not a function
    at Object.<anonymous> (C:\Users\chris\.atom\packages\require\views\require-view.js:3:32)
    at Module._compile (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\native-compile-cache.js:103:30)
    at Object.defineProperty.value [as .js] (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\compile-cache.js:208:21)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:313:12)
    at Module.require (module.js:366:17)
    at require (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\native-compile-cache.js:50:27)
    at Object.<anonymous> (C:\Users\chris\.atom\packages\require\index.js:2:19)
    at Module._compile (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\native-compile-cache.js:103:30)
    at Object.defineProperty.value [as .js] (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\compile-cache.js:208:21)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:313:12)
    at Module.require (module.js:366:17)
    at require (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\native-compile-cache.js:50:27)
    at Package.module.exports.Package.requireMainModule (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\package.js:715:27)
    at C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\package.js:117:28
    at Package.module.exports.Package.measure (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\package.js:92:15)
    at Package.module.exports.Package.load (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\package.js:106:12)
    at PackageManager.module.exports.PackageManager.loadPackage (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\package-manager.js:457:14)
    at PackageManager.module.exports.PackageManager.activatePackage (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\package-manager.js:536:30)
    at C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\node_modules\settings-view\lib\package-manager.js:452:29
    at exit (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\node_modules\settings-view\lib\package-manager.js:73:16)
    at triggerExitCallback (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\buffered-process.js:215:47)
    at ChildProcess.<anonymous> (C:\Users\chris\AppData\Local\atom\app-1.7.4\resources\app.asar\src\buffered-process.js:237:18)
    at emitTwo (events.js:87:13)
    at ChildProcess.emit (events.js:172:7)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)

Commands

     -0:10.7.0 core:confirm (atom-text-editor.editor.mini.is-focused)

Config

{
  "core": {}
}

Installed Packages

# User
require, v0.1.0

# Dev
No dev packages

How to reference a package from code
#2

I got this package to install from the command line without error. Fails from GUI PM.


#3

This is a bug in the require package (not in atom) which was already reported here. The package seems to have been abandoned (last change more than 2 years ago), so you should look for alternatives.