[Reopened] Searching / installing packages are too slow


#1

[EDIT: I temporarily closed this issue a month ago when I felt the speed good enough. But recently things turn bad again.]

When I open [Settings > Install] in Atom and search or install packages, which is supposed to be very convenient and fast, I always have to wait around a minute for ANY response.

In comparison, when I go to the website of atom.io, in my web browser, and search or download packages there, the speed is much faster.

FYI: I’m in China and therefore I often have bad connections to many foreign sites. So, I am using a proxy (ShadowSocks) to overcome these problems. It works very well.

However, 1) I CAN visit atom.io WITHOUT my proxy at first place, and 2) [Settings > Install] is just slow, NOT broken.

So it might be something different from my common bad connection problems.


I want to know:

  1. What are the differences between the two ways of package searching?

  2. How can I make the responses in Atom [Settings > Install] as fast as in web browser?

Note: I guess Atom downloads a long index of packages at the beginning of my searching. But why installing a single package is also way too slow?

PS: Recently, even the images of package author’s avatar are slow to load, too. Sometimes timeout and they are broken.


#2

Now, Update Check also goes timeout.

I really need help!


#3

It’s a bit of a moot point comparing with the webpage, very different protocols and connection methods so not the same thing.

Let’s pick up the proxy question again.
Have you had a chance to follow this section about using Atom behind a proxy:
https://atom.io/docs/v1.0.0/getting-started-installing-atom#setting-up-a-proxy


#4

Thank you very much, @batjko !

It works!

For those who are on Windows as well, here’s how to configure:

  1. Open folder [C:\Users\GrandSong\.atom\.apm]
    “GrandSong” is my user name. Replace it with yours.

  2. Find the file “.apmrc”.
    But don’t edit it. It will be auto-generated by Atom!

  3. Copy the file to the parent folder.

  4. Edit this copy. Add:
    https-proxy = http://localhost:1080
    “localhost:1080” is my local proxy.

Note: the official guide says “https://” but “http://” works for me.


#5

Well, I’m in Europe and not behind a proxy and it is always terrible slow. Is atom fetching data from a west coast (US) server?