Removing Trailing Whitespace Not Working All-of-the-Sudden


#1

Very strange. Out of nowhere, in the middle of working on a project that required me to have invisible characters turn on, I noticed that Atom wasn’t stripping out trailing whitespace characters on save as it normally does. I have the whitespace package enabled and I haven’t changed any settings in that regard. Any ideas?


#2

Found the issue. I forgot that I had converted a file from a .txt to a .md file, and was expecting the trailing whitespace of the .txt file to be stripped, but because it is now a .md, it doesn’t strip trailing whitespace, as trailing whitespace is used in markdown. My apologies.