Remove the space after the gutter


#1

I try to remove this space but I can’t.

I’ve use this style in atom style sheet

atom-text-editor .gutter,
.gutter,
:host .gutter{
  min-width: auto !important;
}

But it’s not work.


#2

Does this happen when you start Atom from the command line with atom --safe? It’s likely being caused by a package, and starting Atom in safe mode will disable all community packages so that we can be sure.


#3

No, I’m start it without command line.


#4

You need to start it from the command line in order to figure out if the space is due to a package.


#5

I try this and not working also :frowning:


#6

What’s the computed CSS for that particular region? Is it part of the line number gutter or is it an additional gutter? Do you have anything in your init.coffee that might be creating a second gutter region?


#7

The init.coffee file is empty and no other style for the gutter


#8

Try saving all of your unsaved work and starting Atom with atom --clear-window-state.


#9

The same.
I try to use other PC and found this problem also.


#10

What happens if you rename your .atom folder? You can do this on the command line, or just drop the . from the name (Windows Explorer does not like giving things names with . at the beginning). When you start Atom again, it will generate the default .atom directory for you. When you’re done experimenting, you can return Atom to the state it is now by copying everything in your backup folder into the new .atom.


#11
  1. What are the exact contents of your styles.less?
  2. What selector shows when you:
    1. Open Atom
    2. Open the Developer Tools
    3. Click the element selector tool (see screenshot below)
    4. Hover over the red area in your screenshot
  3. What happens if you:
    1. Completely exit Atom
    2. Move your ~/.atom directory to ~/.atom-backup
    3. Start Atom normally


#13
  1. Some config for Fira Code Font only
  2. The DOM element has class gutter and it’s has style with this selector atom-text-editor .gutter, :host .gutter
  3. Atom Start without all my and packages setting and the space founded also :smiley: