Refinements to the Not Responding / Keep Waiting dialog


#1

I have a similar problem to the one described in Lag, crash, but Atom doesn’t crash, so I thought I better make a new message… (That’s why I chose the Features category, not the Support one.)

At home, I have a rather old computer (with Windows 10 now) often nearing filling its 4 GB of memory.
When I start Atom, or when I activate it while its memory was swapped out after a while of inactivity, I get the above described message:

Editor is not responding

The editor is not responding. Would you like to force close it or just keep waiting?

Keep Waiting / Close

The message itself is rather OK. If I click Keep Waiting, the editor often resumes. It is nice that Atom is aware of wait time and responsiveness.

The main issue is that this dialog is modal and blocking.

I saw a similar dialog in Chrome, for example. But at least, when the browser resumes (swapping ends, for example), it is able to auto-close the dialog, as it is no longer relevant.
Here, I can wait a long time, I haven’t seen any auto-close, and the editor is indeed reactive when I click Keep Waiting.

That’s all: a suggestion to keep checking if the editor becomes reactive while displaying the dialog.
And perhaps a way to adjust the time before displaying the dialog, for old computers…


Disable self-fulfilling modal warning at start about Atom being unresponsive?
#2

hi, I am the same problem. for me it’s fine if you run atom in safe mode (atom --safe) or when you rerun atom.


#3

It’ s pretty old, but someone might find it useful:

When atom starts in safe mode, it doesn’t load packages. It means, that the long waiting times, and dialog that appears is caused by one of your packages. Try to turning them off one by one, and find the faulty one.