Recursive directory created while using Atom


#1

While using Atom, I copied a single file into my project. Atom encountered and error and asked if I would like to close, as other editors often do. I asked it to remain open, but soon my computer stopped responding. After restarting, I discovered that while crashing, it created an infinite structure of files /x/y/x/y/x/y/x/y/… that never ends. I was doing a simple copy and paste. There should have been no way that I asked it to infinitely nest these folders. I have had trouble with atom in the past and found that I can’t copy files into atom, and must do that in other editors or the file explorer. I am now unable to delete this file structure despite researching various methods that have worked for others. Using robocopy to attempt to delete it, I was able to see that the files are nested hundreds of levels deep, before robocopy crashed and could not delete the folders. I have never heard of this happening to anyone else while using Atom, but I have to admit that I am feeling uncomfortable about copying and pasting with this text editor now. Has this ever happened to anyone else? Why did it happen? I would like to continue using atom.


#2

This is impossible to answer without a lot more detailed information. The best course of action is to open a bug on https://github.com/atom/atom with as exacting a set of repro steps as you can remember. If you can figure out a way to make it happen consistently, that would be even better.

On the other hand, it could be a one-off thing that may be nigh impossible to reproduce.


#3

I know it’s an old thread but here’s how this happened for me: In the atom treeview, i right-clicked -> copy on project folder, then created a backup folder inside of the project folder, then tried to paste the copy inside that backup. it crashed and found i had a super-nested empty directory.
robocopy worked for me but if anyone still needs help (and on windows) there are other things to try here: https://stackoverflow.com/questions/8460268/delete-a-very-very-deep-tree-of-subdirectories-on-windows


#4

I had this problem too, in Windows 10 and Atom v.1.27.2 x64. I not sure of the exact actions that created the problem…probably moving a subfolder to a different position in the tree view. It’s a quite serious problem because the nested folder structure is not erasable with the standard commands. I deleted them running a script adapted from this answer https://superuser.com/a/425666. I hope it helps.