Receiving error: "read ECONNRESET" during any package operation


#1

I have searched for this and found several references, but they all indicate proxy issues and I am not behind any firewalls (disabled anti-virus, too). I did see one reference to ‘flaky internet connection’ and I can say that mine is less than optimal, but this is consistent. I tried uninstalling, deleting the ‘leftover’ files in my documents folder, everything that I can think of. Running Win 10 Pro. I had platformio up and running several months ago and diverted from that project, but now I want to try it again. Thank you for any tips that you can provide!


#2

Hmmm, is it easy for you to try from a different network just to test if the issue is related to your connection?

And for completeness, can you confirm whether there’s any difference if you run from safe mode (atom --safe)? Also can you share:

  • your version information:
atom -v
apm -v
  • a screenshot of the error

#3

I did as you suggested and the issue continued. Going down that same path I tried a fresh install on a freshly created virtual Win 10 Pro to try ruling out my workstation. Success. I learned several things from this exercise: proper problem isolation technique, using virtual boxes has advantages, my deficiencies, and humility. Thank you! I must add how refreshing it is to get prompt, courteous and helpful support.


#4

Awesome, glad you have things up and running now :raised_hands:


#5

I just ran into this myself - using Atom 1.20.0 x64 on Windows 10.

To resolve the issue, I added an exception in the Windows firewall for
C:\Users<username>\AppData\Local\atom\atom.exe
and also for
C:\Users<username>\AppData\Local\atom\Update.exe

(replace the part with your username)

All is now working fine.