React and react-router versioning with electron 1.2.6


#1

I apologize for the question if the answer is int he documentation, but i couldn’t find what i was looking for.

Do all the specific versions of electron version lock on react and react-router? We are using 1.2.6 but we’re making some changes, and i wanted to be sure that

react 0.14.8 and react router 2.6 are upgradable in this case.

If there is a spot in the documentation or some package file which lists out all the dependencies please point me there.

Thanks!


#2

The React DevTools only work out of the box in Electron 1.2.1 or later. That aside Electron has no dependencies on React, nor vice versa.


#3

@enlight thanks for the information.