R documentation loads slowly when passed to browser for Atom


#1

I’m using Atom as my R IDE. I have R integrated with Atom through the Hydrogen, Jupyter, Rbox setup. Everything works great, except for when I need to access the R documentation.
If I run the commands
library(ggplot2)
print(?facet_wrap)
via Atom, my web browser opens, and it tries to load the appropriate document page, but it takes several minutes to load.
The same commands in the base R gui load the documentation page in my web browser in less than a second.
I also tried ?facet_wrap
in Atom, this produces a check mark instantaneously, but no output.
In the base R guiI the appropriate documentation page loads in my browser in less than a second.
Any thoughts on how to resolve this would be greatly appreciated


#2

Atom has nothing whatever to do with the process of loading the documentation as you’ve described it. As soon as Hydrogen sends the instruction to the kernel, the rest of the process happens elsewhere. I also think you’re troubleshooting this wrong. You shouldn’t be comparing the performance of Hydrogen to the interface (it sounds like a REPL) shipped with R. You should compare Hydrogen to Jupyter. The slowdown is probably entirely based in the action of the R kernel and whatever code sits on top of the interpreter to make it compatible with Jupyter. You should run that test and make sure there’s no difference between Hydrogen and Jupyter in how they behave, and if so you should ask the people who have expertise regarding IRkernel.


#3

Thanks for the clarification. My apologies if I posted the question in the wrong place. I just switched to Atom, as part of the solution that lets me write my R scripts by voice, and I don’t have a solid grasp of everything that’s going on under the hood yet. I did the test you suggested, and discovered that running the same command in a Jupyter notebook, running in PlatformIO Terminal, results in lightning fast load time. It’s only when I the commands in the standard scripting pane, that there is an issue. Does this still mean it’s related to the IRkernel, or is it the Hydrogen package? Now that I found a workaround, is there still value in reporting the bug to the appropriate entity?


#4

There might be something to do with how Hydrogen sends the command off, but it could be more complex than that. I don’t know how to ask the right questions to figure out exactly where the delay is.

We don’t know what the bug is, or if there is a bug, exactly (it works, just not quickly). The first thing you should do is lay out the situation to a person or group who know about the software in question (the IRkernel repo) and ask for help in troubleshooting to find the root cause.