Question-- please help!


#1

I have downloaded atom on a computer running Debian, dpkg wont install, the error i'm getting is:

    $ sudo dpkg -i atom-amd64.deb
Selecting previously unselected package atom.
(Reading database ... 131313 files and directories currently installed.)
Preparing to unpack atom-amd64.deb ...
Unpacking atom (1.0.19) ...
dpkg: dependency problems prevent configuration of atom:
 atom depends on libgtk2.0-0.
 atom depends on libudev0 | libudev1.
 atom depends on libgcrypt11 | libgcrypt20.
 atom depends on libnotify4.
 atom depends on libxtst6.
 atom depends on libnss3.
 atom depends on python.
 atom depends on libcap2.

dpkg: error processing package atom (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Errors were encountered while processing:
 atom

Help please!


#2

Atom depends on some other packages in the Debian package repository that you don’t have installed. Try installing all the packages listed as atom depends on <package> with apt-get. After that you may also need to run apt-get install -f. Run the following from your command line:

sudo apt-get install libgtk2.0-0 libudev1 libgcrypt20 libnotify4 libxtst6 libnss3 python libcap2
sudo apt-get install -f