Question about soft wrap


#1

Hi,

Seriously new to Atom - like day 2 of using it, and I’m doing some examples from a textbook. I’m typing a paragraph in

(yes its html, i’m just started learn web development, gotta start somewhere)…anyway…there’s NO word wrapping, the line just keeps going and going and going, does Atom not word wrap? or is that what the {RETURN} key is for?

Just wondering how Atom handles things like this?

Thanks

Bootz


#2

Codenewbie myself! I get it :slight_smile:
In the view tab there is an option called Soft Wrap. You can access it from the View tab->Toggle soft wrap.


#3

tried that, did not alter of saved file, nor did it alter current can keep typing away like crazy on one line. no hot keys for it, like Atl or CMD or something I dunno…i’m on 1.15


#4

Before you select soft wrap Is your cursor on the selected file for example:


#5

I tried it with NO files open, initial start up :), there’s a faint vertical line in Atom, which I am assuming is where a normal page might end, wrap to the next line), but I just haven’t figured out how to make it active, I can try again, from first opening. no biggie.


#6

@AndreaGriffiths11 is citing the correct feature, Soft Wrap. You can set it and it will change any newly opened editors, so you should be able to close a file you have open and then open it again to see the change. Or you can use my soft-wrap-indicator package to change the soft wrap setting for an editor that is already open.


#7

okey doeky, didn’t see her response, ack, lemme give it go :slight_smile:


#8

nope didn’t do anything…see screen shot


#9

PS: don’t mind the gobbly gook, I was testing it out, I’m just running through some HTML examples in a textbook :slight_smile: , wanna see functionality…then get creative with it all :slight_smile:


#10

Here’s what I did using Atom v1.15.0 on Mac OS X 10.12.3:

  1. Launched Atom in my local atom repository
  2. Opened the Settings View
  3. Went to the Editor settings tab
  4. Scrolled down and checked “Soft Wrap”
  5. Opened static/index.html in the Atom project
  6. Used Cmd+K Right to split it into a second pane
  7. Closed the original copy in the left pane
  8. Typed a lot of blah

As seen in the screenshot, soft wrapped text :+1: Notice also the text shading behind “Wrap” in the status bar indicating that soft wrap is enabled in that editor.


#11

If you want to make a sticky,its all good. I found the answer: There’s actually 2 different spots for Soft Wrap.

The 1st screen shot shows the menu option under View 3rd item from the bottom - it has no hot keys.

See SECOND POST BELOW, (restricted to 1 image per post) :slight_smile:


#12

SECON POST (2 of 2)

The 2nd screen shot shows it in Menu Option [ATOM] -> [PREFERENCES] -> [<>EDITOR] -> Opens ->

<> EDITOR SETTINGS


You won’t see the item straight away, but scroll down to below Invisibles Its the 10th item in the list from Invisibles

Maybe that’s what everyone is looking for?

Ok, maybe I be a dumb ass or something, while LeeDohm’s answer is awesome. I couldn’t find “Settings View”, also, for whatever reasons, CMD + K + RIGHT ARROW (►) it didn’t appear to do anything, but there could be alot I’m missing.

I thank you all for humouring me with this discussion, it has lead down more thought provoking threads than simply looking for a “soft wrap” …and that is awesome.

Bootz :slight_smile:


#13

Hey Leedohm - what does static/index.html do? I do not see an open command? what part of the project did you put it? does it matter? (first, beginning lines, middle, end)? Does it only alter that project, or all projects? what does it do? This is a little confusing, when I added into the project below the previous work. I got this?

(see image)

Screen Shot 2017-03-24 at 8.20.23 AM (3)

(see bottom of image text)


#14

But When I put it at the very beginning of a project, 1st line of code, I got this


#15

@rsese Would you mind helping out from here? I’m going to be in meetings all day today but I want @Bootz to get where they need to go :grinning:


#16

BTW: In case anyone wants to know why there maybe (1) or (2) or (3) in the screen shot name at the end, its because I run 3 monitors, 2 external HP 25XI’s, + the laptop monitor, so when you screen print, it captures all 3 screens, and labels them (1), (2), (3) :slight_smile:

Bootz


#17

Will do :+1: @Bootz, I’ll try to address your earlier questions first, let me know if it makes sense or not :v:

Yep you’re correct :+1: though the 2 spots you found are a bit different. The View menu item will toggle soft wrap for the current file you have open at the time and the soft wrap setting you found in Atom > Preferences > Editor is the default setting. So the default setting could be checked so that files soft wrap by default, but for some particular file, you could disable soft wrap and it wouldn’t affect the Atom > Preferences > Editor setting.

Hope that part makes sense, let me know if you have questions about that.

Sorry for any confusion here, “Settings” and “Preferences” mean the same thing, they’re both the Settings View. So when you went to Atom > Preferences, that was the Settings view Lee was referring to.

I had a bit of trouble with panes and this key combo too initially - first use Cmdk and then after that, hit the right arrow button and that should open a second pane.

I’m going to grab lunch really quick but I’ll look through your next questions when I’m back :fries:


#18

Hi there,

OK, cleared up a few things…so what I would refer to at

ATOM -> Preferences -> ETC>ETC>ETC>

it is more commonly referred to as the SETTINGS VIEW? (just wanna clarify),

The default word wrap, does work, I just tested it out on a new piece of gobbly goook…so its wrapping YAY…not sure why I would ever want to turn it off, but heck ya never know…not sure it why it defaulted as OFF…but again I know little.

As for CMD + K + > it did work…

Although could someone answer this question?

Why is it when I open up Atom I get 5 window panels opening

1: Last Project worked on
2: Untitled
3: Welcome
4: Settings
5: Welcome Guide?

Do I really need all of these things open, maybe I’m old school, but I’d rather open the program, then go to CMD O to open up the folder, I mean in theory I could have 2 or 3 projects on the go at the same time, couldn’t I?

Oddly I’m looking at the Welcome Guide more closer, and it says Open a Project, Install a Package et.cetc. then on the far right side, its showing all my word documents and txt files? i just think its opening anything it can? kinda weird isn’t it?

Thanks a bundle

Bootz


#19

Going to the Settings View and unchecking the “Restore Previous Windows on Start” option should do the trick.


#20

Thanks WIIu, but also I had to uncheck the check box for show welcome page middle of the page, ack, not in View Settings area, but right on the first page (why is it the simplest things are lost to complex minds) :slight_smile: