Python Language Server


#1

I am on a Mac running OS 10. I started using Atom for Python3.7 projects. I have installed the Python Language Server using the following command in terminal: python3.7 -m pip install ‘python-language-server[all]’. However, I get a prompt everyone time I start Atom that the python language server needs to be installed.

I have followed the instruction in the IDE-Python package. See attached image of error prompt.


#2

Look at the command in the error message. It says python, and you installed under python3.7. You have multiple versions of Python on your computer and you need to either change which version is behind the python command or change the settings of the ide-python package (Settings -> Packages -> ide-python). It’s right at the top.


#3

Thanks! Got it done!