Python error during build instructions on Win 8.1


#1

I tried to build atom-shell following the instructions on Build instructions (Windows). But I can’t get past the step Bootstrapping. I get the following output:

$ python script/bootstrap.py
Traceback (most recent call last):
  File "script/bootstrap.py", line 121, in <module>
    sys.exit(main())
  File "script/bootstrap.py", line 25, in main
    update_atom_modules('atom/browser/default_app')
  File "script/bootstrap.py", line 75, in update_atom_modules
    execute([apm, 'install'])
  File "C:\Users\Martin\Source\Repos\atom-shell\script\lib\util.py", line 136, in execute
    output = subprocess.check_output(argv, stderr=subprocess.STDOUT)
  File "C:\Python27\lib\subprocess.py", line 566, in check_output
    process = Popen(stdout=PIPE, *popenargs, **kwargs)
  File "C:\Python27\lib\subprocess.py", line 710, in __init__
    errread, errwrite)
  File "C:\Python27\lib\subprocess.py", line 958, in _execute_child
    startupinfo)
WindowsError: [Error 2] The system cannot find the file specified

Do you have any idea what I can do to make it work? I copied the output from cygwin (64-bit), but I get the same error on Windows PowerShell (both are run as admin).

My setup is:

  • Windows 8.1
  • Visual Studio 2013
  • Python 2.7.8 (default, Jun 30 2014, 16:08:48) [MSC v.1500 64 bit (AMD64)] on win 32
  • 32-bit node.js
  • git version 1.9.4.msysgit.0

#2

Is there a reason to build it? Chocolatey is easy to use (avoid the gui).


#3

Might be too obvious, but is Python installed in that folder (i.e. C:\Python27)?
If so, can you find the files it mentions: C:\Python27\lib\subprocess.py and probably more importantly: C:\Users\Martin\Source\Repos\atom-shell\script\lib\util.py?


#4

Thanks for the quick response. The files mentioned are in the following paths:

  • C:\Python27\Lib\subprocess.py (there is an upper case L in Lib)
  • C:\Users\Martin\Source\Repos\atom-shell\script\lib\util.py

@batjko I changed the first path to a lower case “lib”, but get the same error.

@mark_hahn I want to try making the shell work on Windows Vista. According to the Dependency Walker there are two functions in user32.dll, which keep the shell from starting on Vista: RegisterTouchWindow and CloseTouchInputHandle. Though I couldn’t find them anywhere occur in the source (?).


#5

I deinstalled Python and installed 32-Bit Python and started the whole process from the beginning (git clone etc.). But the error remains the same. I read on the internet that this message might have something to do with the environment variable ComSpec, which is set to %SystemRoot%\system32\cmd.exe on my system. Any idea what I can try. Has someone Windows where the bootstrap script doesn’t fail and can check his Python version?


#6

You mention Windows 8.1 and Windows Vista. Which one are you trying to build for again?


#7

I have been building Atom (not atom-shell) on Win7 and Win8.1 over the past few months, always using Python 2.7.7. Don’t actually remember if it was 64bit, but I think so.

Now, I would be surprised if your 2.7.8 makes the difference, but who knows.


#8

Actually I’m trying to build it on Windows 8.1 (I think Windows 7 SP1 is a minimum requirement for VS 2013). I know the shell (like Atom itself) officially doesn’t support Windows Vista. My intention is to try and see what steps are necessary to make it run there as well. Chromium and node.js do even support XP I think (as build target).


#9

I have the same problem, any solution?


#10

I solved this creating (by hand) a npm folder in AppData\Roaming


#11

Thanks, that did it for me, too! Problem solved. Maybe someone could update the docs with a troubleshooting hint?

@nexon How did you figure it out?

@batjko Thanks, I tried many different versions of Python with no effect.