Python 3 - The system cannot find the path specified (when running code)


#1

I’ve encountered this problem with the Hydrogen package since I updated atom and its packages a couple days ago, not having changed anything since the last time it worked.

Additional information:
It appears to find the kernel for Python 3 - Hydrogen kernels updated: Python 3.
At first it didn’t seem to work for neither Script nor Hydrogen packages, but after adding another line to the PATH variable, the Script package seems to be able to run the code.
I’m using Anaconda’s version 3.6.5 of Python.
I’ve tried uninstalling Anaconda and installing Python 3 alone, but it didn’t work. I have also reinstalled Anaconda completely, aswell as Atom (but for some reason it remembered the packages I had installed with their respective configurations, so maybe it wasn’t a complete uninstallation).
Output for atom --version:
Atom : 1.30.0 Electron: 2.0.5 Chrome : 61.0.3163.100 Node : 8.9.3

Note that I’ve searched over a whole variety of other posts but either I didn’t understand what they were saying (I’m quite new to programming), they weren’t exactly alike, or their solutions were already applied to my problem.


#2

Trying to uninstall Hydrogen also gives the following error:
Failed to delete Hydrogen: EPERM: operation not permitted, unlink ‘C:\Users\Mario.atom\packages\Hydrogen\node_modules\zeromq\build\Release\zmq.node’


#3

Reinstalled Hydrogen manually by deleting the folder and reinstalled it using the Atom interface but it still gives the same error.


#4

For the Hydrogen-specific part of this question, you may need to ask on the hydrogen repository. It uses a special method of connecting to the code interpreter and, since I don’t use the package, I don’t have any expertise there. I can help you debug script all day, or any other package that uses Node’s child_process.spawn() to run a command-line instruction.

Correct. Your packages and configurations live in the .atom/ folder in your user folder.


#5

I managed to get some more info which may mean it’s not related to Hydrogen, but I honestly have no idea.


Does this bring some light to the issue?


#6

It’s definitely Hydrogen related; those git errors, while annoying, are not unexpected or indicative of a problem.

I don’t know what throws that error, but does toggling Enable Debug Messages in Settings -> Packages -> Hydrogen provide more info in the dev tools console?


#7

I had it enabled already, but it had filtered out those four messages down below. I’m not sure if it’s useful.


#8

Solved. kernel.json file in python3 had an incorrect path.


#9

Can you please explain what steps you took to resolve the problem?