Publishing Package: Unable to find remote helper for 'git+https'


#1

I don’t mean to publish issues twice to put up pressure or anything, but I’ve made the experience that feedback on the forum is more likely than on GitHub issues.

I’ve been away for some days (so obviously I didn’t actively change my Atom setup) and since my return I can no longer publish packages.

$ apm publish patch
Preparing and tagging a new version ✓
Pushing v1.10.3 tag ✗
fatal: Unable to find remote helper for 'git+https'

I’ve experienced this on several computers, both with an existing local repo and a fresh clone. Is anybody else experiencing this as of lately?

PS: I’m aware of this post, but it’s of no help at all


#2

I have the same issue


#3

Interestingly, not all of my packages are affected. As a workaround, you can use apm publish --tag <tag>. Please consider subscribing to the issue, you might be able to provide some valuable information.


#4

thanks for the link, after some trial and error i took off git+ in the URL for respository in package.json and it doesn’t have this issue anymore


#5

Cheers, that worked! Editing my package.json solved the problem.

Before:

"repository": {
    "type": "git",
    "url": "git+https://github.com/idleberg/atom-browse.git"
}

After:

"repository": {
    "type": "git",
    "url": "https://github.com/idleberg/atom-browse.git"
}

#6

I had the same symptoms, so I removed the “git+” from my “url,” and I got farther, but apm publish patch is still requesting a username/password, which doesn’t work with 2FA enabled. apm login doesn’t seem to work. I’ve tried git clone git@github://... instead of apm develop my-package with the same results.