Publishing package failed (due to second git account?)


#1

I’ve tried to publish my package for the first time, but it failed when uploading the new version to github. Probably because I’m using my private account for it, which isn’t the main git account on my computer (but it’s the one registered with atom).

Anyway, this as far as I came:

GitHub Username or Email> andrecedik
Password>
Two-Factor Authentication Code> 1234567890
Saving token to Keychain ✓
Registering capybara-snippets ✓
Preparing and tagging a new version ✓
Pushing v0.1.0 tag Username for 'https://github.com': andrecedik
Password for 'https://andrecedik@github.com':
✗

remote: Invalid username or password.
fatal: Authentication failed for 'https://github.com/andrecedik/capybara-snippets.git/'

Afterwards a git status told me

Your branch is ahead of 'origin/master' by 3 commits.

So I pushed the changes made by APM to my repository. But, unfortunately the Atom package page didn’t get updated because of this (as you can see here: https://atom.io/packages/capybara-snippets). Is there a way to tell the Atom site update itself?

Using apm version v0.1.0 isn’t helping because it just returns:

Preparing and tagging a new version ✗
npm ERR! Error: Version not changed

Any clues are highly appreciated!


#2

Did you try running apm publish --tag v0.1.0?


#3

Awesome!
Thank you so much for the pointer Kevin.

It didn’t work with apm publish --tag v0.1.0 at first, because GitGub didn’t know the tag, but after publishing it to GH, the command worked fine and the package description on atom.io is now up 2 date.