Publishing Error - Creating new version failed: Not found


#1

Been trying to publish my package, but not matter what I try I keep getting a ‘Creating new version failed: Not found’ error

apm publish --tag 1.3.0
Registering autocomplete-ionic ✓
Publishing autocomplete-ionic@1.3.0 ✗
Creating new version failed: Not found

Yet I can see it in my releases and tags on my github page. What I am missing?


#2

Did you delete and recreate the repository? I’m not seeing the package in the package listing:

https://atom.io/packages/autocomplete-ionic


#3

Trying to publish it for the first time. Is there a step I am missing?

Chris


#4
  • Have you done apm login?
  • Are you in the root of your package development directory when you execute the apm publish command?
  • Are you on the master branch?
  • Do you have push access from that machine?
  • Have you tried apm publish --tag v1.3.0? (Since v1.3.0 is the actual name of the tag. I don’t use the apm publish --tag version of the command, so I don’t know if that’s necessary.)

#5

Yes :frowning:
Deleted the local copy and resynced it from the repo then did apm login, add my token from atom.io
Verified that I am at the root of the package. There is only a master branch, so that is ok.
Did a push from the GitHub Client to the repo, then a sync.
then tried apm publish --tag v1.3.2 and got the same error.

Thoughts?


#6

I don’t know if there is some other thing that goes along with apm publish --tag, but I don’t think so. I would typically just use apm publish [major|minor|patch]. It increments the version number, creates the tag, pushes everything and then publishes the package.

You should probably post an Issue on https://github.com/atom/apm. I don’t have access to the back end database that GitHub uses to manage this stuff.

One final question, did you try to publish the package and then delete and recreate the GitHub repository and try to publish again?


#7

There was a cross linkage that did occur and Ivan Žužak was helping me resolve that.

I had a version published but it pointed to the wrong repo.

Chris


#8

Yea several people have reported this when they had the wrong repo link in their package.json, which could have many reasons, but it’s easy to trip over.


#9

I have tried again a few times, still with the same error. sigh.


#10

I have same issue!

I’m trying to publish a tomorrow-night-syntax, but I can’t.

apm publish --tag v1.0.0
Registering tomorrow-night-syntax ✓
Publishing tomorrow-night-syntax@v1.0.0 ✗
Creating new version failed: Not found

#11

According to the docs the version field in package.json must be 0.0.0 when publishing a package for the first time. Can apm publish --tag bypass this rule?
I guess if you want to publish v1.0.0 then you should just prepare you package as described in the docs and execute apm publish major.

EDIT: I don’t know about publishing a v1.3.0 though.


#12

I don’t believe that it requires it to be 0.0.0 when publishing the first time. It just requires the field to be present and filled in with some valid semver version number if you use the apm publish [major|minor|patch] command.


#13

In my specific case, I deleted the repo and rebuilt it under a slightly different name and it published without a hitch.


#14

Great!
I could publish my theme https://github.com/kyoh86/tomorrow-evening-syntax

Thanks!


#15

@kyoh86 You know it would help people a lot to see a screenshot of what your theme looks like with code in the editor.
Your current image on the README gives some idea but seeing it on an example would be much better.