Published as package not theme?


#1

So I screwed up. Followed the instructions for creating a ui theme and then followed the instructions posted here… now I’ve published a package… not a ui theme. Any ideas what I did wrong, and how to fix it ?


Publishing Theme Using apm
#2

A theme is just a package that has a theme tag in its package.jsonfile. Examples:


#3

Yeah I forked the atom-dark-ui so my package.json should be fine. However it still shows up as a package not a theme https://atom.io/packages


#4

In forking it, you brought over all the tags … then you reset the version number to v0.0.0 and then did what appears to be an apm publish minor which updated the version number to v0.1.0 here:

https://github.com/ericjbasti/responsive-dark-ui/commit/6e0be0cb513a3157b45768325a8aa217cdb20fea

The problem is, there already was a v0.1.0 tag from eight months ago:

https://github.com/ericjbasti/responsive-dark-ui/tree/v0.1.0

This probably messed up the versioning and such. I wouldn’t be surprised that if I tried to install your package, I got the eight month old version.


#5

Got it. So I shouldn’t have really forked the theme. I should have just created a whole new repo or perhaps skipped the step about setting the version to “0.0.0”.

Should I be starting over or would simply changing my version number work. I’m trying to avoid being the idiot with a theme as a package for too long.

Thanks for the quick replies.


#6

To be honest, I don’t know. I would try just updating the version number to the last tag and then doing an apm publish minor from there.

I’ve actually forked a syntax theme and incremented the version number and it worked fine (it is recognized by the system as a theme):