Progress Bars & Busy Signal


#1

I’ve noticed the following in my IDE and would appreciate any insight into them.

First Question: I’ve installed the busy signal package and I assume it is doing what it is supposed to but does anyone know if the color of the little busy signal dot mean anything? The one on the package documentation page is green but mine is more an amber color. Is that an indication of anything? Also, let’s say I run a Julia script. Even after I kill the script the little busy signal persists as if Julia were still running even though the Julia console has says I terminated the process. Is this intended?

Second Question: I’ve noticed a bluish progress bar in the bottom left of my screen when I run a Julia script. I assume this is basically another type of progress indicator? I have no idea where it came from. Also - if anyone knows what it is, is the color an indication of anything?
image

Please let me know what you think.


#2

Green means idle (not doing anything). Orange (and changing size) means something is happening. Mousing over it will make a box appear with the current and past tasks.

Does is persist indefinitely, or does it stop a while after? This may be a bug, but I don’t know which package is causing it. If you can work that out, I’ll take a look.


#3

Hey, thanks for the response.

It persists indefinitely. I killed the script yesterday shortly before I posted. I just checked after having my computer idle (sleep) for more than 15 hours and it still says it is “busy”. I’ve confirmed it isn’t (killed the script and my Task Manager indicates the CPU is idling).


#4

Thebusy-signal package isn’t as smart as that; it is completely controlled by the package that started the process. I.e., the package explicitly tells busy-signal to start, and needs to explicitly tell it to stop. It’s completely independent of the actual process.

This is why I need to know which package started it, as that is the one that’s not stopping it correctly.


#5

Okay - How can I help? How can I determine which package started it?


#6

It would be the one you’re using to run the Julia script. If you’re not sure which it is, you could try disabling packages.