Problems with atom, config.cson and gpu acceleration


#1

I am currently trying out atom on all my devices. While installation was painless on most I am having a little trouble on my arch system.

The problem resides with gpu acceleration, when I run atom normally I just get a blank white screen. This is solved with the --disable-gpu flag. Great. However I don’t want to have to open a terminal all the time to run atom so I would like to automate this.

I have had a poke around in the config.cson file and added the following under editor:

editor:
    useHardwareAcceleration: false 

However this still does not allow me to start atom without the --disable-gpu flag.

Could someone tell me if this line is correct for the .cson file?


#2

Hopefully of some use:
Disabling Hardware Acceleration (--disable-gpu) on Windows?


#3

Yeah I was gonna do it with a quick bash script but just wanted to make sure there wasn’t a better way first haha. Thanks