Problems using OTA on ATOM

#1

Hi there,

I am trying to use OTA programimg on my NodeMCU device. I already make it work on Arduino IDE, Command Prompt and WIndows PowerShell.
But on ATOM, didn’t get answer from device.
I tried to run manually inside ATOM PS, but same error.

Outside ATOM:
C:\Users\mauricio.costa\Desktop\Home>python.exe C:\Users\mauricio.costa.platformio\packages\tool-espotapy/espota.py -i 192.168.0.32 -p 8266 --auth= -f C:\Users\MAURIC~1.COS\Documents\PlatformIO\Projects\TEX_Server_Temp_Monitor.pioenvs\nodemcuv2\firmware.bin -r true -d true
22:48:50 [DEBUG]: Options: {‘timeout’: 10, ‘esp_ip’: ‘192.168.0.32’, ‘host_port’: 19561, ‘image’: ‘C:\Users\MAURIC~1.COS\Documents\PlatformIO\Projects\TEX_Server_Temp_Monitor\.pioenvs\nodemcuv2\firmware.bin’, ‘host_ip’: ‘0.0.0.0’, ‘auth’: ‘’, ‘esp_port’: 8266, ‘spiffs’: False, ‘debug’: True, ‘progress’: True}
22:48:50 [INFO]: ** ESP OTA script **
22:48:50 [INFO]: Starting on 0.0.0.0:19561
22:48:50 [INFO]: Upload size: 319376
Sending invitation to 192.168.0.32
22:48:50 [INFO]: Waiting for device…
Uploading: [============================================================] 100% Done…

    22:48:57 [INFO]: Waiting for result...
    22:48:57 [INFO]: Result: 912OK
    22:48:57 [INFO]: Success

Inside ATOM:
PS C:\Users\mauricio.costa\Documents\PlatformIO\Projects\TEX_Server_Temp_Monitor> python.exe C:\Users\mauricio.costa.platf
ormio\packages\tool-espotapy/espota.py -i 192.168.0.32 -p 8266 --auth= -f C:\Users\MAURIC~1.COS\Documents\PlatformIO\Projec
ts\TEX_Server_Temp_Monitor.pioenvs\nodemcuv2\firmware.bin -r true -d true
>>
22:58:53 [DEBUG]: Options: {‘timeout’: 10, ‘esp_ip’: ‘192.168.0.32’, ‘host_port’: 53195, ‘image’: ‘C:\Users\MAURIC~1.COS
\Documents\PlatformIO\Projects\TEX_Server_Temp_Monitor\.pioenvs\nodemcuv2\firmware.bin’, ‘host_ip’: ‘0.0.0.0’, ‘auth’
: ‘’, ‘esp_port’: 8266, ‘spiffs’: False, ‘debug’: True, ‘progress’: True}
22:58:54 [INFO]: ** ESP OTA script **
22:58:54 [INFO]: Starting on 0.0.0.0:53195
22:58:54 [INFO]: Upload size: 319376
Sending invitation to 192.168.0.32
22:58:55 [INFO]: Waiting for device…
22:59:05 [ERROR]: No response from device

#2

You might find more help on the PlatformIO message board?