Problems in launching atom (Windows)


#1

Hello,

I have installed atom with following version:
Atom : 1.20.0
Electron: 1.6.9
Chrome : 56.0.2924.87
Node : 7.4.0

I had installed go packages in atom. After creating and editing a file, the editor just crashed. However I didn’t see any errors while working. Since then I am not able to launch atom, there’s no action when I launch it and no errors flashed. Please help resolving this.


#2
Hello. 
Sorry to hear about your troubles.

How are you currently trying to launch the software? (Example: short-cut from desktop)

Use http://flight-manual.atom.io/hacking-atom/sections/debugging/ as a reference.
See if you can start Atom in safe mode.

Greetings.

#3

Yes, I launch from the shortcut. I will launch from command line and then post back.


#4

I followed the link given for debugging. So tried first from command line without the --safe option, I just called atom. The editor still launches. And again I tried with --safe option from command line and the editor launches. My init file does not contain anything. So without uninstalling any package I tried to open with the shortcut, now it launched without any problem. I am able to edit go code.

The previous crash had happened while I was editing. I will have to wait and check if it crashes in the similar way and I see similar problem.


#5

<joke>
What is your DHL account number?
I’ll send you a hammer to hit Windows into submission.
</joke>

Hard to say what the issue is/was.
Especially weird that the short-cut now works.
My best non-expert opinion has memory overlap as cause.
Not to say it is at the Atom’s core either.

Please work with your files as to expect trouble: save regularly and have backups at the ready. Keep us posted of any more occurrences… special notice on what functionality you used.

Others might need to know:

  • Did you restart the PC at any point in time before launching from the terminal?
  • Which version of Windows?
  • Any anti-virus packages installed?

Good luck.
- Dan


#6

haha

I’ll post here if I am able to recreate this. I’ll keep a backup of my work, thanks.

And:

  • I did not restart my PC
  • I am on windows 7 pro SP1
  • And I do have norton AV installed (does that matter?)