Problem with platformio-ide-terminal on Mac

I installed the platformio-ide-terminal package and noticed that when I copy the path to a file, if it contains spaces, it does not put backslashes and therefore from error. How can the problem be solved?
Thank you.

You could put the backslashes in yourself.

Is there not the possibility that it does it automatically, like when using the Mac terminal application? In fact on the Mac terminal, if I copy a path of a file that contains spaces there is just the paste text function with Escape characters.

There’s the possibility, for sure, but someone has to write the code to modify what gets sent to the clipboard. It’s not hard, but it’s more work than manually inserting a couple of backslashes, because you’d have to modify the package’s code. If you want to try, I can guide you in setting up a development copy of the package. Do you know how to use git?

No, you’re right, maybe it’s not worth it. As long as I try to give names to files and folders without spaces, the problem is solved. Thanks anyway.

Marco

1 Like