Problem with package installation


#1

Hey,

I’m new to Atom and like it very much. Unfortunately it doesn’t support german keyboards. When I want to install a package (Keyboard-localization) it says “Searching failed”. Additionally when clicking on settings/packages I can’t download them. It just says loading packages…

Can someone help me please?

Thanks!


#2

It sounds like you may be running behind a proxy. Have you checked out the proxy information here:


#3

There souldn’t be a proxy, but I will try. Where should I run the commands? Just add the commands to config.cson or where?

Thanks for your help!


#4

Run the commands at the terminal. It will save the settings for you.


#5

I understand that I have to execute those commands in the terminal, but where can I open the terminal? Is there a shortcut or something?


#6

Hey

@leedohm is referring to the OS command line. In OSX and Linux that’s Terminal and in Windows it’s the DOS command line.


#7

Sorry I’m not very talented in those things, I just want to turn the german keyboard on… why is it that complicated in Atom?

When I use the DOS command line of Windows it shows an error “can’t find the command”. I typed in: apm config set https-proxy https://9.0.2.1:0

Thanks for your help!!


#8

Because of a long-standing bug in Chrome, unfortunately. (See the links in the FAQ entry on it for more details.) There may be a light at the end of the two-year-long tunnel though. We have to do some more testing once we integrate Electron v0.37.x into Atom:


#9

To be able to use apm you probably need to set your PATH.