Problem with multi-cursor key-bindings


#1

I have a problem with these on OS X - the default keybindings CTRL-UP and CTRL-DOWN have standard system key-bindings in OS X that take precedent over the ones in Atom. I tried remapping the system ones, but they still don’t work in Atom. Tried to remap them in Atom, but I can’t figure out exactly which binding these are in the list.

(I would love it if I could just do this via Alt-drag of the mouse as in Sublime Text :wink:


#2

Here’s what I did to map Ctrl+Up and Ctrl+Down:

  1. Open the OS X Keyboard Preferences
  2. Click the Shortcuts tab
  3. Select “Mission Control” in the left-hand list
  4. Uncheck both “Mission Control” and “Application Windows” in the right-hand list
  5. Switch to Atom
  6. Add the following to keymap.cson and save
'body':
  'ctrl-up': 'command-palette:toggle'
  'ctrl-down': 'command-palette:toggle'

As soon as I did that, both keys would toggle the Command Palette.

Have you tried using the Keybinding Resolver (Cmd+. on OS X and Ctrl+. on other platforms)? It will show you what key Atom saw you press and the command that was triggered because of it.


#3

Thanks @leedohm Still not working but the Keybinding Resolver helped - Seems Emmet takes the CTRL-UP and -DOWN bindings. Will try remapping those.

ps. tried remapping the Emmet keybindings in keymap.cson, but seems the emmet.cson takes precedent over that. I can edit that, but changes would be blown away if the Emmet package is updated, right?

pps. ok, opted for simplified emmet instead of emmet, and that solves that - thanks again