Problem with focus in panes


#1

To reproduce:

  1. open a new pane (same document in both panes)
  2. Select something in one of the panes and cut it
  3. Switch to the other pane, and press Enter somewhere (to create the line where you want to paste what you cut)

Result: focus switches back to the pane where you did the cutting, so if you paste at that point, you simply put the cut contents back where they were.

Expected result: focus stays in the second pane, so if you paste at this point, the clipboard contents are pasted in the new line you created there.


#2

Actually, since they’re both the same document … it doesn’t matter where you paste it because it’s the same document. It’ll show up in both panes. But you’re right, it shouldn’t change the focus. Do you have a repro that doesn’t involve the same document?


#3

In a way you’re right, it doesn’t matter since it’s the same document, but in fact, it does, because it’s different points in the same document – the first time this happened, I wasn’t paying close attention, and was baffled as to why the contents I had just moved were still in the same place.

I haven’t yet seen this with multiple docs, but will test and see if the behavior is the same.


#4

Ah ok. I didn’t realize you were pasting into a different place. Can you file a bug on Atom Core (if there isn’t one already) and link it back here? Be sure to explicitly state in the bug that you’re pasting into a different place :grinning:


#5

will do - and btw, did test with different files, and it doesn’t happen then…


#6

filed bug: https://github.com/atom/atom/issues/3441


#7

Just responded on the issue, referencing another one which seems to be at least closely related.
Have you tried this in safe mode by any chance?


#8

no, haven’t tried in safe mode yet. Actually, I don’t know how to launch Atom in safe mode … :wink:


#9

Ah, I did mention it on the issue you opened on the repo. Launch atom from the command line using this switch: atom --safe and all packages will be disabled, so you confirm whether one of them caused it.


#10

Ok, did test in safe mode – same behavior…so not a package on this one.